From: matz@... (Yukihiro Matsumoto) Date: 2002-04-01T12:31:55+09:00 Subject: Re: String#begins?(s) Hi, In message "String#begins?(s)" on 02/04/01, Tim Sutherland writes: |class String | def begins?(s) | self[0...(s.size)] == s | end |end | |Worthwhile? I don't like the name "begins?". It's not obvious. I don't like names like "beginWith?" or "begin_with?" neither. matz. p.s. If you can find a good name, you've accomplished 90% of the job.