From: Chris Date: 2010-09-08T20:38:38+09:00 Subject: Small improvements ideas ? Hello, I would like to know how to shorten these two lines 1) doit() if my_string && my_string.downcase == 'hello' 2) doit() if one_var && (my_string =~ /this_regexp/) == nil Case 1) is a way to check for my_string beeing nil (would break on downcase call). But it's verbose, nothing better ?? Case 2) I want doit beeing call if regexp don't match. would I use ! (my_string =~ /this_regexp/) but I don't like using ! because it's not very readable and I can't use not keyword in this case Thanks