From: Philipp Kempgen Date: 2010-08-15T05:02:15+09:00 Subject: kind_of?( NilClass ) Should I write var.kind_of?( NilClass ) or simply var == nil ? I have the feeling that kind_of?(NilClass) is more "proper"/"clean" but then again it decreases the readability and might not even be necessary. Are there any situations where it makes sense to subclass NilClass? Regards, Philipp