From: "David A. Black" Date: 2010-08-02T02:48:59+09:00 Subject: Re: .any?{} Behavior Hi -- On Mon, 2 Aug 2010, Hal Fulton wrote: > On Sun, Aug 1, 2010 at 12:24 PM, Hal Fulton wrote: > >> On Sun, Aug 1, 2010 at 11:46 AM, Rick DeNatale wrote: >> >>> On Sun, Aug 1, 2010 at 12:28 PM, Maurizio De Santis >>> wrote: >>>> Josh Cheek wrote: >>>>> On Fri, Jul 30, 2010 at 10:49 AM, Rick DeNatale >>>>> wrote: >>>>> >>>>>> [].all? {|element| element != 3 } # => true >>>>>> There may be a better name than non_vacuous_all? but I can't think of >>> one. >>>>>> >>>>>> >>>>> How about #appall? to imply that it is a pessimistic implementation of >>>>> #all? >>>>> :) >>> >> >> > Sorry, hit send by accident. > > How about 'every?' for the non-vacuous 'all?'? > > If we really need one, that is. Or maybe "all?!" :-) David -- David A. Black, Senior Developer, Cyrus Innovation Inc. The Ruby training with Black/Brown/McAnally Compleat Philadelphia, PA, October 1-2, 2010 Rubyist http://www.compleatrubyist.com