From: Hal Fulton Date: 2010-08-02T02:25:32+09:00 Subject: Re: .any?{} Behavior --0016e6de04c4ca9f96048cc65ef1 Content-Type: text/plain; charset=ISO-8859-1 On Sun, Aug 1, 2010 at 12:24 PM, Hal Fulton wrote: > On Sun, Aug 1, 2010 at 11:46 AM, Rick DeNatale wrote: > >> On Sun, Aug 1, 2010 at 12:28 PM, Maurizio De Santis >> wrote: >> > Josh Cheek wrote: >> >> On Fri, Jul 30, 2010 at 10:49 AM, Rick DeNatale >> >> wrote: >> >> >> >>> [].all? {|element| element != 3 } # => true >> >>> There may be a better name than non_vacuous_all? but I can't think of >> one. >> >>> >> >>> >> >> How about #appall? to imply that it is a pessimistic implementation of >> >> #all? >> >> :) >> > > Sorry, hit send by accident. How about 'every?' for the non-vacuous 'all?'? If we really need one, that is. Hal --0016e6de04c4ca9f96048cc65ef1--