From: Maurizio De Santis Date: 2010-08-02T01:28:21+09:00 Subject: Re: .any?{} Behavior Josh Cheek wrote: > On Fri, Jul 30, 2010 at 10:49 AM, Rick DeNatale > wrote: > >> [].all? {|element| element != 3 } # => true >> There may be a better name than non_vacuous_all? but I can't think of one. >> >> > How about #appall? to imply that it is a pessimistic implementation of > #all? > :) I think that the best name for that method would be def all!?(&block) !empty? && all?(&block) end It's a pity it is not permitted! so I propose def strict_all?(&block) !empty? && all?(&block) end -- Posted via http://www.ruby-forum.com/.