From: Caleb Clausen Date: 2010-07-06T22:34:31+09:00 Subject: Re: MiniTest test case execution On 7/6/10, George Thomas wrote: > Hi, > > I have MiniTest derived class to run the test cases. > > Its something as follows > > class CustomClass < MiniTest::Unit::TestCase > def test1 > end > def test2 > end > ..... > ..... > def testn > end > end > > My requirement is that if the logic inside test1 fails , I do not want > to execute other tests. (test2 onwards) > > (Calling exit , seem to be exiting from test1 only) Consider rewriting it like this: rename test1..testn to check1..checkn and write a toplevel test like this: def test_all_of_them test1 test2 .. testn end