From: "Guy N. Hurst" Date: 2002-03-20T01:48:52+09:00 Subject: Re: dots in Dir.entries Garance A Drosihn wrote: > ... > I will admit that in 99.8% of the scripts that I've written, > I have to filter out those two directories. But for the > other 0.2%, I can't just blindly add them. The 'ls' command > has both 'ls -a' and 'ls -A', where the only difference is > whether those two are included in the listing. It might > make sense for ruby to have both Dir.entries and some other > method -- except that I can't decide on a good name for that > other method... :-) Dir.entries_all ? > Either that, or let people use `ls -a` -- yes, if they need what the actual OS provides, that is always an alternative. :-) Perhaps a Struct containing the actual output from such a command would be useful, like Etc does? Guy N. Hurst