From: Bob Alexander Date: 2002-03-20T01:12:11+09:00 Subject: Re: dots in Dir.entries I'd like to point out that the way the RCR ended up being submitted, the suggestion is to have new method names to produce the "children-only" lists: Dir::children(path) (returns a list) Dir::each_child(path) (iterates) I chose this approach for the RCR (based on feedback from ruby-talk) because: o It can't possibly break existing Ruby programs. o It works for both camps -- those who like the filtering idea and those who don't. I don't think the new method names will cause any confusion. The names are probably easier to remember than their existing counterparts (Dir::entries and Dir::foreach). In fact, if these methods are available I doubt that Dir::entries and Dir::foreach will continue to see much use. Bob