From: Colin Bartlett Date: 2010-04-04T09:19:31+09:00 Subject: Re: combined ranges... On Sun, Apr 4, 2010 at 12:47 AM, Intransition wrote: > On Apr 3, 11:47 am, Colin Bartlett wrote: > >> On Sat, Apr 3, 2010 at 2:30 PM, Intransition wrote: >>> I am going to add this to Facets, but I have to decide for sure on the >>> name. Which is better?   #visit   #traverse   #recurse   other ? > >> I know they are long names, but because it's a recursive each, why not >>   #each_recursively (Facets already uses recursively) or #each_recursive >> (I prefer the latter - shorter!) and maybe have visit as a short alias? > > Yes, I was thinking of #recursive_each as well, since that name is > also along the lines of #reverse_each. On the other hand #recurse is > nice and short and to the point. Some time after suggesting #each_recursive it occurred to me that a possibility is #each_each which (apart from the issue of objects which have an each method but which don't mix in Enumerable) sort of says what it does. Then we could also have #each_each_with_index, Array#reverse_each_each, etc.