From: Marko Schulz Date: 2002-03-16T10:20:42+09:00 Subject: Re: camelCase and underscore_style On Sat, Mar 16, 2002 at 09:14:30AM +0900, Nathaniel Talbott wrote: > Guy N. Hurst [mailto:gnhurst@hurstlinks.com] wrote: > > > Actually, there was a discussion about this last year > > somewhere and it was concluded by those involved that > > underscore_style was for > > verbs (methods), and CamelCase was for nouns (like classes). > > This is not a requirement, of course, but seems consistent > > with what I have come to expect, and is what I follow. Last fall there was a discussion on Ruby Garden, spawned by a proposed Ruby Coding Convention: http://www.rubygarden.org/article.php?sid=134 > ... when someone at the RubyConf said that when he saw someone using > camelCase in their code, he identified them as not having fully grokked > Ruby. Sounds stupid to me. > One comment I read in the list a while back about camelCase vs. > underscores that I thought was interesting is that for non-native > English speakers, underscore names are much easier to read. I heard that before too, but could never comprehend it. I am not a native English speaker and prefer camelCase. -- marko schulz