From: Joel VanderWerf Date: 2002-03-16T09:26:47+09:00 Subject: Re: camelCase and underscore_style Nathaniel Talbott wrote: > I agree completely with those two (classes and methods)... the hard ones > for me are variable names and file names. Variable names are tough > because they have a way of turning in to method names, i.e. I have an > instance variable, and I decide to expose it, thus it's a variable name > AND a method name. I've decided to go with underscores for all my > variables for exactly this reason. I suppose I could still use camelCase > for temporary variables, but I think madness lies that way. I use underscore for variables because of prefixing and other symbolic operations: thing --> next_thing array --> sum_array Preserving the relationship is good both for human readability and for machine readability (e.g. case-sensitive greps).