From: Matt Armstrong Date: 2002-03-16T01:33:52+09:00 Subject: Re: camelCase and underscore_style "Morris, Chris" writes: > Pete: >> (umm ... lost the msg, but he said, to him, > underscore_style_was_easier_to_read) > > I agree with Ron on the typing point, and after giving the > underscore style a try, I think it is easier to read one thing with > the underscore style, but I find a whole block of code with lots of > underscored names in it distracting, because my eye is drawn to the > underscores. Or is a code block with lots of underscored names a > code smell? :) I personally find underscore_style easier to read, especially with tired eyes after coding for too long. Somebody agrees with me and wrote an Emacs mode that translates camelCase into underscore_style while you edit. http://www.lickey.com/env/elisp/glasses.el -- matt