From: Nathaniel Talbott Date: 2002-03-15T11:04:01+09:00 Subject: RE: testunit - setup -> set_up ? Yukihiro Matsumoto [mailto:matz@ruby-lang.org] wrote: > In message "RE: testunit - setup -> set_up ?" > on 02/03/14, "Nathaniel Talbott" writes: > > |Ah, but JUnit uses setUp... two words. So which is the "xUnit way?" > > I just miss "setup" just for its conciseness. Woah... pressure comes to bear ;-) Actually, with the experience fresh on my mind of writing a couple of emails about this whole thing and accidentally typing "setup" instead of "set up" _every_ time I used it, I'm beginning to agree. It makes me feel really wishy-washy, but I'll survive. To avoid more floundering, let me bring up a couple of other name changes I'm pondering: #assert_raises -> #assert_raised #assert_nothing_raised -> #assert_not_raised #assert_throws -> #assert_thrown #assert_nothing_thrown -> #assert_not_thrown I'll keep thinking about #setup vs. #set_up, and get back to ya'll. Nathaniel <:((>< + - - | RoleModel Software, Inc. | EQUIP VI