From: Dave Thomas Date: 2002-03-14T07:38:03+09:00 Subject: Re: testunit - setup -> set_up ? "Nathaniel Talbott" writes: > For #setup, there is another issue: it fails silently. I've converted > code from Lapidary to Test::Unit several times and had it suddenly stop > working. Aack! What's wrong? Oh, I forgot to rename #setup to #set_up. > This is dangerous and just plain aggravating. There are two solutions. > One is to issue a warning if you have a method named #setup. Another is > to alias #setup to #set_up (actually it's not as simple as aliasing, > which is part of why I don't like this option, but I can do it). Nathaniel: I agree with you about aliasing. I'd suggest simply going with #setup and dropping #set_up. Like it or not, xUnit is pretty much the de facto framework now. Bucking that will inevitably bite people. While set_up might be correct, #setup is probably right. Dave