From: Matt Armstrong Date: 2002-03-14T06:40:40+09:00 Subject: Re: testunit - setup -> set_up ? "Morris, Chris" writes: > I'm just starting to use testunit instead of rubyunit ... I noticed > with an existing RUNIT::TestCase, when I changed it over to > Test::Unit::TestCase, setup wasn't called, it's now set_up. Why the > change and can testunit alias setup to set_up? As you probably know, you can use the RubyUnit compatibility layer if you want RubyUnit code to work out of the box. Test::Unit isn't supposed to be backwards compatible -- it looks like it uses a words_separated_by_underscore naming scheme throughout. You'll find lots of other changes to the API beyond just setup->set_up, so this change alone won't help you avoid auditing all of your test code. Other things will break as code is cut and paste between the two. Personally, I don't think I'll bother converting my old RubyUnit code to Test::Unit framework, simply because Test::Unit has a good RubyUnit emulation. It was easier for me to report the bugs in the RubyUnit emulation to Nathaniel and have him fix em. :-) -- matt