From: Albert Schlef Date: 2010-02-04T06:00:36+09:00 Subject: Re: Parsing text with while loop. Felix Feelx wrote: > That is why [...] (I think) using FasterCSV wouldn't help that much either. This CSV library at least parses the file correctly for you. CSV has some quoting rules and merely spliting by "," isn't very robust. BTW, I find your code a bit hard to read. Maybe because of all the long variable names. Tip: instead of referring to some_variable[14], some_variable[7], etc., you can do: created, name, place, duration = some_variable.values_at(14, 7, 6, 20) (I think it's more readable.) -- Posted via http://www.ruby-forum.com/.