From: Ryan Davis Date: 2010-01-31T13:59:25+09:00 Subject: Re: Refining the use of file joins or file expand_path On Jan 30, 2010, at 18:24 , Alpha Blue wrote: > Ryan Davis wrote: >> My version: >> >>> require "x/ui/blah1" >>> require "x/ui/blah2" >> >> assuming: >> >>> lib/x/ui/blah[12].rb >> >> It is 100% easier to read, maintain, and understand. There's no magic, >> and nothing to debug because you don't pull in stuff you didn't expect. > > That doesn't work for all operating systems. As pointed out by others... yes... yes it does. For ruby's definition of "all" that is.