From: Yossef Mendelssohn Date: 2009-11-17T04:42:13+09:00 Subject: Re: Enumerable#find_yield, useful shortcut? better name? On Nov 16, 4:41 am, Brian Candler wrote: > Unless I have misunderstood, I think there is an almost identical > facility built-in: > > >> [1,2,3].find(lambda {-1}) { |x| x > 10 } > > => -1 You have misunderstood. The desire is to do something when a match is found, not if there is no match. -- -yossef