From: Intransition Date: 2009-11-14T14:12:58+09:00 Subject: Re: Enumerable#find_yield, useful shortcut? better name? On Nov 13, 5:13 am, Martin DeMello wrote: > On Thu, Nov 12, 2009 at 9:37 PM, Intransition wrote: > > This method has long been suggested to me as #map_detect. At first I > > wasn't sure of it's usefulness. But now I think it's okay. (Your > > thoughts?). In any case, the name has to go. Currently I'm thinking > > #find_yield. Any better suggestions? > > #where doesn't read too badly I agree. But to me #where also conveys the same meaning as #select. Plus I tend to like it's use in higher-order messaging, and I have no desire to tread on those toes. However, you did get me thinking in a different direction which ultimately led me to #found, which conveys it's relation to #find and that we want, not the element itself, but what was "found". Though I admit, it has a strange tense for a method name.