From: Aaron Patterson Date: 2009-11-13T01:41:42+09:00 Subject: Re: Enumerable#find_yield, useful shortcut? better name? On Fri, Nov 13, 2009 at 01:07:41AM +0900, Intransition wrote: > This method has long been suggested to me as #map_detect. At first I > wasn't sure of it's usefulness. But now I think it's okay. (Your > thoughts?). In any case, the name has to go. Currently I'm thinking > #find_yield. Any better suggestions? I would call the method "unnecessary". Especially since we already have a built in syntax which is more concise: [1,2,3].find { |_| false } # => nil [1,2,3].find { |_| false } || 1 # => 1 -- Aaron Patterson http://tenderlovemaking.com/