From: Marc Lee Date: 2009-10-01T11:59:02+09:00 Subject: Can someone help me please with event machine? I'm getting an error with event machine, being unable to connect to the server.. I'm using the AMQP gem. tcp_connect: inp=0xba201f8 err=EADDRINUSE /Users/maleko/workspace/geo/vendor/gems/gems/eventmachine-0.12.8/lib/eventmachine.rb:811:in `connect_server': no connection (RuntimeError) from /Users/maleko/workspace/geo/vendor/gems/gems/eventmachine-0.12.8/lib/eventmachine.rb:811:in `reconnect' from /Users/maleko/workspace/geo/vendor/gems/gems/amqp-0.6.0/lib/amqp/client.rb:172:in `reconnect' from /Users/maleko/workspace/geo/vendor/gems/gems/amqp-0.6.0/lib/amqp/client.rb:85:in `call' from /Users/maleko/workspace/geo/vendor/gems/gems/amqp-0.6.0/lib/amqp/client.rb:85:in `unbind' from /Users/maleko/workspace/geo/vendor/gems/gems/eventmachine-0.12.8/lib/eventmachine.rb:995:in `call' from /Users/maleko/workspace/geo/vendor/gems/gems/eventmachine-0.12.8/lib/eventmachine.rb:995:in `run_deferred_callbacks' from /Users/maleko/workspace/geo/vendor/gems/gems/eventmachine-0.12.8/lib/eventmachine.rb:995:in `times' from /Users/maleko/workspace/geo/vendor/gems/gems/eventmachine-0.12.8/lib/eventmachine.rb:995:in `run_deferred_callbacks' from /Users/maleko/workspace/geo/vendor/gems/gems/eventmachine-0.12.8/lib/eventmachine.rb:242:in `run_machine' from /Users/maleko/workspace/geo/vendor/gems/gems/eventmachine-0.12.8/lib/eventmachine.rb:242:in `run' from /Users/maleko/workspace/geo/vendor/gems/gems/amqp-0.6.0/lib/amqp.rb:81:in `start' Thanks... It's stumped me and my mates on this one. Cheers -- Posted via http://www.ruby-forum.com/.