From: Ryan Davis Date: 2009-09-30T12:02:02+09:00 Subject: Re: syntax translation Java - Ruby On Sep 29, 2009, at 09:24 , Jake Brightmatter wrote: > have this code in Java: > > boolean monkey = true; > for(i=0; monkey; i++){ > if(index[i] == null) { > put.something.new(i); > break; > } > } > > I am aware that it makes no sense by itself so I will explain. I am > iterating through a (Sequel) database nodes. I am looking for a node > I.D. that is not being used. Basically, I am looking for and open > parking spot. When I find one, I insert my new data using the newly > found parking spot. I really can't figure out why I need to uniquely > identify each node by an I.D. as it is already uniquely identified by > location in the tree but that is a different matter entirely. All I > need is how to write a nice infinite 'for' loop in Ruby. No, that's what you THINK you want because you're coming from java... index is a bad name for a collection, so I'm going to call it parking_spots. parking_spots.each_with_index do |parking_spot, i| next if parking_spot parking_spots[i] = my_car break end but honestly if you're doing this against a sequel db, you're it wrong. You should use the power of the DB instead of doing tons of roundtrips in ruby.