From: Matt Brooks Date: 2009-09-17T01:39:32+09:00 Subject: Re: Array of Hashes in an array of hashes - Complicated! Matt Brooks wrote: > 2.) Is there a way to make the 'signal_index' a variable? I would like > to be able to store the contents of a variable as the name that is then > associated with a value. > > like this possibly? I want the contents of parameter_name to be the > label or name associated with the contents of the variable > parameter_value > @signals[signal_index].add_variable(#{parameter_name}, parameter_value) nevermind on #2, I got that to work! @signals[signal_index].add_variable(parameter_name.to_sym, parameter_value) -- Posted via http://www.ruby-forum.com/.