From: Kyle Schmitt Date: 2009-06-11T00:58:05+09:00 Subject: Re: centos and ruby 1.9.1 - possible? Just re-read this message, make sure you've got the development packages for openssl and zlib installed, as well as any other dev packages for libraries you want to use (gdbm& sqlite would be good examples). CentOS 4.x is old, we only use it where we need an Oracle approved install. 4.5 is very old, you may want to upgrade to 4.7, it could make life easier (but upgrading to 5.3 would make it a LOT easier). You can tell configure to not check the zlib version, which may or may not be safe, depending on what will be exposed to the outside world. If for example you're writing a web-app where people can upload compressed files for whatever reason, it would be very very dangerous. On the other hand if you're never touching zlib, you may be able to ignore it. On Wed, Jun 10, 2009 at 8:24 AM, Älphä Blüë wrote: > When I attempted a compile it failed because much of the dependencies > were not already built on the distro.  I compiled from 1.9.1 source but > zlib, openssl, etc. - all of those failed.  When I tried to update zlib > it said I had the latest available already but I noticed that the > version was "old".  So, where do I get the latest zlib?