From: Pra Bhandar Date: 2009-05-28T01:44:52+09:00 Subject: Re: Can't start webrick as the root user Thanks for everyone's response. The application was starting but not finding the right directory after the login as a non-root user which I mistakenly thought was due to port conflict. All I had to do was look at the strace output more closely. Now with the right directory, it works without any issues. I was barking up the wrong tree - and and am really appreciative for folks who responded quickly. As far as the root user vs non-root user discussion, the application does need to be started as a non-root user since I don't want to have support groups needing root password. This piece of puzzle was for init.d configuration so that the root user kicked off the daemon after a server bounce. Thanks. Prakash Brian Candler wrote: > Pra Bhandar wrote: > >> The log file shows the following - >> >> [2009-05-22 04:46:37] INFO WEBrick 1.3.1 >> [2009-05-22 04:46:37] INFO ruby 1.8.7 (2009-04-08) [x86_64-linux] >> [2009-05-22 04t:46:47] WARN TCPServer Error: Address already in use - >> bind(2) >> [2009-05-22 04:46:47] INFO WEBrick::HTTPServer#start: pid=30733 >> port=8192 > > This is a WEBrick bug (which I reported separately a long time ago). It > has successfully bound to port 8192, as the final line confirms. The > bind error log message is spurious. -- Posted via http://www.ruby-forum.com/.