From: Jeff Schwab Date: 2009-05-16T00:20:03+09:00 Subject: Re: Whaaaaat? Rick DeNatale wrote: > On Fri, May 15, 2009 at 9:30 AM, Jeff Schwab wrote: >> Rick DeNatale wrote: >>> On Fri, May 15, 2009 at 7:25 AM, Jeremy Henty >>> wrote: >>>> On 2009-05-14, Jeff Moore wrote: >>>> >>>>> 1.9.1 adds Enumerable#reduce as synonym (which makes more sense to >>>>> me) and still retains inject >>>> Is one of #reduce or #inject deprecated in 1.9.1? >>> Don't think so. >>> >>> Actually IMHO which makes more sense is situational. >> Really? I never heard of "inject" in any other language. It was always >> "reduce" to me. I got the impression that "inject" was just a cutesy way of >> making the method name similar to detect, select, collect, and reject. > > So did you stop reading my reply at that point? No, but I did somehow have a brain fart. Apologies. > And if you want to let languages vote on what the 'correct' name > should be It's not a question of correctness. Both inject and reduce are clearly correct in their own context. It's purely a matter of clarity. > maybe it should be fold: When I've seen "fold" it has meant something completely different, despite what Wikipedia says. I'm not claiming right or wrong here, just relating my own experience. There's no need for you to take offense, nor to reply with such an arrogant and condescending tone.