From: Gregory Brown Date: 2009-05-14T12:07:09+09:00 Subject: Re: [bikeshed] Syntactic sugar idea On Wed, May 13, 2009 at 11:03 PM, Daniel DeLorme wrote: > Yes, I know, and that was kind of my point. The to_proc conversion > became popular because people want a shortcut notation for this common > case, but IMHO map(&:foo) is way uglier than map{.foo}, and as a bonus you > could even do map{.foo.bar}  :-) I don't know. I think they're about the same in terms of looks, and the former doesn't require changes to the parser. -greg