From: Daniel DeLorme Date: 2009-05-14T11:42:31+09:00 Subject: [bikeshed] Syntactic sugar idea It seems that often an object will be passed into a block only to invoke a method of that object: arr.map{ |obj| obj.some_method } So I had the (weird? stupid?) thought that it would be nice to have some syntactic sugar like this: arr.map{ .some_method } Does that make any sense?