From: RichardOnRails Date: 2009-04-10T11:50:04+09:00 Subject: Re: DRY up consecutive gsub's - How to On Apr 9, 9:25 pm, RichardOnRails wrote: > Hi, > > I have a csv file suitable for an Excel display.  The file has column- > names on certain row. > > In order to process subsequent rows I want to refer to their columns > symbolically using the column-names. That requires the column-names to > be cleaned up in order to create valid Ruby symbols. > > The following worked fine: >         if col_name >           col_name.gsub!(/[\s]/, "") >           col_name.gsub!(/[&]/, "And") >           col_name.gsub!(/[#]/, "Number") >         end > > Each of the following one-liners failed: >          col_name.gsub!(/[\s]/, ""). gsub!(/[&]/, "And").gsub!(/[#]/, > "Number") if col_name >          col_name.gsub(/[\s]/, ""). gsub(/[&]/, "And").gsub(/[#]/, "Number") > if col_name > > Can either of the one-liners be made to work? > > The code is show in a larger (easier to read) context athttp://www.pastie.org/442456 > > Thanks in Advance, > Richard > > . Hi Philip and Robert, Thank you both for great responses. First off, I still wanted to know what was the flaw in my one-liner; I found two: 1. I needed carefully placed parenthesis 2. The parenthesized version failed because I just discovered) gsub! returns nil when no change is made. Bad idea for my purpose; no doubt Matz saw a good reason for it. Bob, your version worked fine and fulfills my goal Ditto for your version, Robert. For both, I appended "if if col_name" to handle unnamed columns. With two great choices, my aesthetics lead me to Robert's version because: 1. I like the x.gsub! ... better than x = x.gsub ... 2. The single gsub! with the choices laid out in order packs expanding it for additional cases with the least typing. Again, thank you both very much for your help. Best wishes, Richard Most of all, I like one-liners much better than 5-liners for readability.