From: Paganoni Date: 2009-04-08T04:34:09+09:00 Subject: Exceptions : should I else or not ? Hello, when writing stuff like that begin call_this() do_that() tell_them() print "Ho yes #{my_dear} you did it" rescue SomeException => e # snip end Should I move the print statement to the else part of begin/end catch block ? begin call_this() do_that() tell_them() rescue SomeException => e # snip else print "Ho yes #{my_dear} you did it" end I presume that the result is the same, but for clarity I would prefer the second solution - Now, what happen if the print statement fails or if my_dear() raises something ? I'll not catch it losing the benefit of the begin/end. So, even if easier to read, is else really useful/a good idea ?