From: Jacek Podkanski Date: 2002-02-04T21:37:46+09:00 Subject: Re: Gtk::Clist question Thank you for your help. Neil Conway wrote: > On Sun, 2002-02-03 at 22:37, Jacek Podkanski wrote: >> Hi, >> Does anyony know whats wrong. I get following error, but from Gtk >> Reference I could expect a Fixnum, if I understood it right (which I >> doubt), but this expects some Object, so what should i do to be able to >> remove a row from a Clist. > > Hmmm... for some reason, Ruby-Gtk calls the method #remove_row, not > #remove. The #remove method you're calling is actually defined in a > superclass, Gtk::Container#remove. > > I can't see of an obvious reason why this would be; what I'll probably > do is rename #remove_row to #remove and add #remove_row as an alias for > backwards compatibility. If anyone has an objection to this, speak up > now. > > Cheers, > > Neil Conway > Ruby-Gtk maintainer > -- Jacek Podkanski