From: "David A. Black" Date: 2009-02-01T05:13:22+09:00 Subject: Re: Object#singleton_class in Ruby 1.9? On Sun, 1 Feb 2009, Robert Dober wrote: > On Fri, Jan 30, 2009 at 4:28 PM, Yukihiro Matsumoto wrote: >> Hi, >> >> In message "Re: Object#singleton_class in Ruby 1.9?" >> on Fri, 30 Jan 2009 20:15:17 +0900, "David A. Black" writes: >> >> |> Was Object#singleton_class (or #eigen_class or #meta_class) planned for >> |> Ruby 1.9 or 2.0? >> | >> |Not that I remember hearing about. I'd certainly like to see it. >> >> We still don't have consensus on the name. eigenclass? >> In that case, should we rename singleton_method to eigenmethod? >> >> matz. > > Actually I am totally against it, in core that is. It would be nice to > have a standard library extension for this, e.g. meta-ruby. > I was really impressed about by David's keynote at Rubyconf. Just > thought to share this thoughts in case I am not a minority. I'd like to have a singleton_class method, but even if there isn't one, I would definitely not like a meta-ruby standard extension. It suggests much too clear a separation between programming and metaprogramming in Ruby, whereas part of the coolness of the language is how interoperative it all is (e.g., the very fact that singleton methods are stored in classes, which in turn fit into the whole class/object model in a predictable way). David -- David A. Black / Ruby Power and Light, LLC Ruby/Rails consulting & training: http://www.rubypal.com Coming in 2009: The Well-Grounded Rubyist (http://manning.com/black2) http://www.wishsight.com => Independent, social wishlist management!