From: Gregory Brown Date: 2009-02-01T02:18:12+09:00 Subject: Re: Object#singleton_class in Ruby 1.9? On Sat, Jan 31, 2009 at 8:12 AM, Sean O'Halpin wrote: > On Fri, Jan 30, 2009 at 3:28 PM, Yukihiro Matsumoto wrote: >> Hi, >> >> In message "Re: Object#singleton_class in Ruby 1.9?" >> on Fri, 30 Jan 2009 20:15:17 +0900, "David A. Black" writes: >> >> |> Was Object#singleton_class (or #eigen_class or #meta_class) planned for >> |> Ruby 1.9 or 2.0? >> | >> |Not that I remember hearing about. I'd certainly like to see it. >> >> We still don't have consensus on the name. eigenclass? >> In that case, should we rename singleton_method to eigenmethod? >> >> matz. > > Personally, I prefer singleton_class. But I would rather it had an > official name than my preference held anything up. > > I suspect there is a strong consensus that it should be named, > whatever the name. I doubt we'll ever get consensus on ~what~ that > name should be. :) Definitely. I was implying that I don't think *too* many people hate singleton_class, but don't get me wrong, even if matz added Object#matz_is_awesome and had it do this operation, I'd be happy. :) -greg -- Technical Blaag at: http://blog.majesticseacreature.com Non-tech stuff at: http://metametta.blogspot.com "Ruby Best Practices" Book now in O'Reilly Roughcuts: http://rubybestpractices.com