From: Suraj Kurapati Date: 2009-01-31T17:16:00+09:00 Subject: Re: File::write() complement for File::read() ? Allow me to rephrase my question: It is currently easier to read whole files (via File::read) than to write whole files (via File::open and passing in a block). This imbalance can be corrected by adding a File::write method, such as the following, to the core Ruby API. def File.write path, data File.open(path, 'wb') {|f| f << data.to_s } end Are there any plans to do this? If not, where can I file a request for such a change? Thanks for your consideration. -- Posted via http://www.ruby-forum.com/.