From: Suraj Kurapati Date: 2009-01-31T14:55:20+09:00 Subject: File::write() complement for File::read() ? Hello, Why is there not a complementary File::write() method to the File::read() method? It feels unbalanced to always write the following code whereas it's so much easier to read a file: File.open(path, 'wb') {|f| f << content } I would like to see this method in the core Ruby API, just as the Symbol#to_proc() facets method has travelled into the core Ruby API. Thanks for your consideration. -- Posted via http://www.ruby-forum.com/.