From: Suraj Kurapati Date: 2009-01-31T04:58:09+09:00 Subject: Re: Object#singleton_class in Ruby 1.9? Thomas Sawyer wrote: > Suraj Kurapati wrote: >> In that case, could we make the names more readable by adding an >> underscore after "eigen"? I find it more difficult to parse the names >> otherwise. >> >> Object#eigen_class >> Object#eigen_methods >> Object#define_eigen_method > > Interesting, I find the other more readable, 'class' is like a suffix to > me, along the lines of 'name' in methods like #basename and #dirname. The problem I have with words like "basename" is that, to me, they are not actually words. For example, I pronounce "basename" as two separate words "base, name" (with a brief pause in between) not as a continuous word "basen-a-me" (without any pause in between). The same applies to "dirname", which I pronounce as "dir, name". In contrast, "singleton" is actually pronounced continuously as "sin-gel-ton", not as "single, ton", so I have no need to insert underscores in that word. In short, how a word is pronounced tells me when to insert underscores. > Just personal preference of course. I'm don't think there is any true > rational for one over the other. I beg to differ and I think there is a rationale (see above). Thanks for your consideration. -- Posted via http://www.ruby-forum.com/.