From: Thomas Sawyer Date: 2009-01-31T04:15:45+09:00 Subject: Re: Object#singleton_class in Ruby 1.9? Suraj Kurapati wrote: > Thomas Sawyer wrote: >> Yukihiro Matsumoto wrote: >>> We still don't have consensus on the name. eigenclass? >>> In that case, should we rename singleton_method to eigenmethod? >> >> Since you make mention of "eigenclass", that would seem to be your bent. >> And I say, go for it! "eigenmethod"? Fantastic! Do it, do it, do it! > > In that case, could we make the names more readable by adding an > underscore after "eigen"? I find it more difficult to parse the names > otherwise. > > Object#eigen_class > Object#eigen_methods > Object#define_eigen_method Interesting, I find the other more readable, 'class' is like a suffix to me, along the lines of 'name' in methods like #basename and #dirname. Just personal preference of course. I'm don't think there is any true rational for one over the other. T. -- Posted via http://www.ruby-forum.com/.