From: Daniel Berger Date: 2009-01-27T12:29:53+09:00 Subject: Re: net-smtp timeout error Thibault wrote: > Hello, > > On Mon, 26 Jan 2009 11:25:14 -0500, Daniel Berger wrote: >> I've got two RHEL3 boxes, alpha and beta. On the alpha box, the >> following script works fine. On the beta box I get a timeout error >> with the same script. What's happening? > > I think you did a check without your script like : > > nc mailhost.foo.com 25 > telnet mailhost.foo.com 25 > > If not I suggest you do so in order to check if your problem really > comes from your script, or from a firewall, routing issue… > >> I did validate that the /etc/resolv.conf and /etc/protocols files were >> the same on both boxes. > > Maybe you could also check with tcpdump to see if packets are > sent/received as attended. > >> This some sort of sendmail config issue? If so, any ideas what it >> might be? > > I don't think so, since you are using SMTP you're bypassing your local > MTA. It turns out there was a bad, hard coded mailhost value in the /etc/hosts file on the beta box. Odd. Anyway, thanks for the reply and the suggestions. Regards, Dan