From: Mike Gold Date: 2009-01-26T23:47:56+09:00 Subject: Re: unalias a method? Todd Burch wrote: > Mike Gold wrote: >> >> The |&block| syntax is supported on 1.8.7+. Rewriting MethodStack for >> 1.8.6 is left as an exercise. > > I had to laugh out loud on that one. Thanks Mike! My last comment sounded more glib than intended. Since I've already used MethodStack in my own code, I think it can be generally useful in cleaning up repetitive alias_method calls. I might try submitting it to facets, with two changes: change names to push_instance_method/pop_instance_method for symmetry with Module#instance_method, and add 1.8.6 compatibility. -- Posted via http://www.ruby-forum.com/.