From: Tom Cloyd Date: 2009-01-02T09:43:12+09:00 Subject: Re: Problem with gem, after upgrading to 1.3.1 on linux (ubuntu 8.04) Pablo Q. wrote: > Ruby doesn't see my installed gems after upgrading to 1.3.1 > > Please help!! > > ~# ruby -v > ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-linux] > > ~# gem -v > 1.3.1 > > ~# gem env > RubyGems Environment: > - RUBYGEMS VERSION: 1.3.1 > - RUBY VERSION: 1.8.7 (2008-08-11 patchlevel 72) [i686-linux] > - INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/1.8 > - RUBY EXECUTABLE: /usr/local/bin/ruby > - EXECUTABLE DIRECTORY: /usr/local/bin > - RUBYGEMS PLATFORMS: > - ruby > - x86-linux > - GEM PATHS: > - /usr/local/lib/ruby/gems/1.8 > - /root/.gem/ruby/1.8 > - GEM CONFIGURATION: > - :update_sources => trueTahks > - :verbose => true > - :benchmark => false > - :backtrace => false > - :bulk_threshold => 1000 > - REMOTE SOURCES: > - http://gems.rubyforge.org/ > > ~# gem list > > *** LOCAL GEMS *** > > net-mdns (0.4) > rubygems-update (1.3.1) > > I tried to run this test file (test.rb): > #test.rb > require 'rubygem' > TRY: require 'rubygems' easy mistake to make - I've done it! > require 'net-mdns' > > ~#ruby test.rb > /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in > `gem_original_require': no such file to load -- net-mdns (LoadError) > from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in > `require' > from test.rb:2 > > I don't know what to do... I have built the ruby and gem from the source but > I don't know how to uninstall it... make file doesn't have uninstall option > > Please help I really don't how to solve this. > > Thanks > > -- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Tom Cloyd, MS MA, LMHC - Private practice Psychotherapist Bellingham, Washington, U.S.A: (360) 920-1226 << tc@tomcloyd.com >> (email) << TomCloyd.com >> (website) << sleightmind.wordpress.com >> (mental health weblog) ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~