From: Garance A Drosihn Date: 2002-01-24T16:56:27+09:00 Subject: Re: Minor thoughts on 'Find' module At 2:52 PM +0900 1/24/02, Garance A Drosihn wrote: >At 2:32 PM +0900 1/24/02, Garance A Drosihn wrote: >>So, I think I want something like: >> >> Find.findx(sort=File::NO_SORT, >> parent_first=true, >> breadth_first=false, >> *srcdirs ) { |aFileName, aFindStat| block } >> >>Other values for sort= would be File::DIR_FIRST File::DIR_LAST and >>perhaps File::ALPHABETIC > >I forgot to explain the other parameters. "parent_first" means that >the code-block will always be called with the parent directory before >it is called with any descendents of that parent. If that value is >false, then the code block will not be called with the parent until >after it has been called for all descendents. It would probably be better for this parameter to be "parent_last" or "send_parent_last" with a default value of false, instead of "parent_first" with a default value of true. Well, it would not surprise me if people came up with better names for all of the options I suggested :-) -- Garance Alistair Drosehn = gad@eclipse.acs.rpi.edu Senior Systems Programmer or gad@freebsd.org Rensselaer Polytechnic Institute or drosih@rpi.edu