From: Marcelo Date: 2008-12-05T01:47:06+09:00 Subject: Re: Enumerable#select used to return actual values On Thu, Dec 4, 2008 at 10:07 AM, Yukihiro Matsumoto wrote: > I don't deny the existence of use case of such method (although > I cannot think of any realistic one right now), but its name > should not be #compact, since it does far more than compacting > the receiver. #transform ? Take something, transform it into something else. Marcelo