From: Yukihiro Matsumoto Date: 2008-12-01T17:05:16+09:00 Subject: Re: Enumerable#select used to return actual values Hi, In message "Re: Enumerable#select used to return actual values" on Mon, 1 Dec 2008 16:53:56 +0900, "David A. Black" writes: |> #each_with_object is an interesting concept. Maybe we can add it to |> the Enumerable if we can come up with a better name. | |But it's in Enumerable already, in 1.9. | |>> RUBY_DESCRIPTION |=> "ruby 1.9.0 (2008-11-12 revision 20227) [i386-darwin9.5.0]" |>> Enumerable.instance_methods(false).grep(/object/) |=> [:each_with_object] Ah, actually I am going to check it in tonight using my time machine. ;-) matz.