From: Lin Jen-Shin Date: 2008-11-05T17:58:35+09:00 Subject: Re: minitest 1.3.0 Released I am sorry, but I encounter a dependency problem. "rfeedparser" depends on "character-encodings", and "hpricot" would load 'encoding/character/utf-8' if available through: begin require 'encoding/character/utf-8' rescue LoadError end Then ::Encoding would be defined, and there's no default_external in ::Encoding! Err, do you mind check RUBY_VERSION? or if Encoding.respond_to?(:default_external) or something like that? Thanks! On Oct 10, 4:21 pm, Ryan Davis wrote: > minitestversion 1.3.0 has been released! > > * > > minitest/unit is a small and fast replacement for ruby's huge and slow > test/unit. This is meant to be clean and easy to use both as a regular > test writer and for language implementors that need a minimal set of > methods to bootstrap a working unit test suite. > > mini/spec is a functionally complete spec engine. > > mini/mock, by Steven Baker, is a beautifully tiny mock object framework. > > (This package was called miniunit once upon a time) > > Changes: > > ### 1.3.0 / 2008-10-09 > > * 2 major enhancements: > >    * renamed tominitestand pulled out test/unit compatibility. >    * mini/test.rb is nowminitest/unit.rb, everything else maps   > directly. > > * 12 minor enhancements: > >    * assert_match now checks that act can call =~ and converts exp to a >      regexp only if needed. >    * Added assert_send... seems useless to me tho. >    * message now forces to string... ruby-core likes to pass classes   > and arrays :( >    * Added -v handling and switched to @verbose from $DEBUG. >    * Verbose output now includes test class name and adds a sortable   > running time! >    * Switched message generation into procs for message deferment. >    * Added skip and renamed fail to flunk. >    * Improved output failure messages for assert_instance_of,   > assert_kind_of >    * Improved output for assert_respond_to, assert_same. >    * at_exit now exits false instead of errors+failures. >    * Made the tests happier and more readable imhfo. >    * Switched index(s) == 0 to rindex(s, 0) on nobu's suggestion.   > Faster. > > * 5 bug fixes: > >    * 1.9: Added encoding normalization in mu_pp. >    * 1.9: Fixed backtrace filtering (BTs are expanded now) >    * Added back exception_details to assert_raises. DOH. >    * Fixed shadowed variable in mock.rb >    * Fixed stupid muscle memory message bug in assert_send. > > *