From: Dave Thomas Date: 2008-10-21T02:44:46+09:00 Subject: Re: instance counter On Oct 20, 2008, at 12:30 PM, Joel VanderWerf wrote: > You're right. They should have an ungainly name, like "class tree > variables", which would help to discourage their use, except in > those rare cases. I personally have stopped using them. When I need the functionality, I use a class instance variable and a class-level attr_accessor to make it available to instances. Dave