From: pachl Date: 2008-10-19T10:29:08+09:00 Subject: Standard File Naming Conventions For a file containing the given class, SomeCoolClass, what would be the proper filename? 1) somecoolclass.rb 2) some_cool_class.rb 3) some-cool-class.rb 4) SomeCoolClass.rb or some other variation? I noticed in the Ruby stdlib, versions 1, 2 and 3 are used.