From: Daniel Berger Date: 2008-10-16T06:49:11+09:00 Subject: Could not find RubyGem - because it's not a gem Hi all, Sorry, a bit of a cross-post here, because I'm not sure if this is a Rails issue or a gems issue. The problem is that I've got sys-admin installed, just not as a gem, and that's causing a problem. First, some config info: RubyGems Environment: - RUBYGEMS VERSION: 1.3.0 - RUBY VERSION: 1.8.6 (2008-03-03 patchlevel 114) [i386-mswin32_80] - INSTALLATION DIRECTORY: C:/ruby/lib/ruby/gems/1.8 - RUBY EXECUTABLE: C:/ruby/bin/ruby.exe - EXECUTABLE DIRECTORY: C:/ruby/bin - RUBYGEMS PLATFORMS: - ruby - x86-mswin32-80 - GEM PATHS: - C:/ruby/lib/ruby/gems/1.8 - C:/Documents and Settings/djberge/.gem/ruby/1.8 - GEM CONFIGURATION: - :update_sources => true - :verbose => true - :benchmark => false - :backtrace => false - :bulk_threshold => 1000 - REMOTE SOURCES: - http://gems.rubyforge.org/ irb(main):001:0> require 'sys/admin' => true However, if I try to fire up Rails I get this: C:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:628:in `report_activate_error': Could not find RubyGem sys-admin (>= 0) (Gem::LoadError) from C:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:139:in `activate' from C:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:163:in `activate' from C:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:162:in `each' from C:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:162:in `activate' from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 31:in `require' from C:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/ active_support/dependencies.rb:510:in `require' from C:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/ active_support/dependencies.rb:355:in `new_constants_in' from C:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/ active_support/dependencies.rb:510:in `require' ... 12 levels... from C:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/commands/ server.rb:39 from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:in `gem_original_require' from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:in `require' from script/server:3 What's happening here? Problem with my setup or environment? Or a problem with Rails? Thanks, Dan