From: kwatch Date: 2008-09-18T08:12:34+09:00 Subject: give me advices about method name Hi, I'm wondering what method names are appropriate for my library. Could you give me advices? Background: I'm developping Motto-mysql library (not released yet). http://github.com/kwatch/motto-mysql/tree/master This library will improve Mysql/Ruby driver. Motto-mysql will add some methods to Mysql::Result class. * Mysql::Result#fetch_one_hash() returns a hash. * Mysql::Result#fetch_one_array() returns an array. * Mysql::Result#fetch_one_object(klass) returns an instance of klass * Mysql::Result#fetch_all_hash() returns an array of hashes * Mysql::Result#fetch_all_array() returns an array of arrays * Mysql::Result#fetch_all_object(klass) returns an array of instances # These methods convert data into proper type (Integer, Boolean, etc) # while Mysql::Result#fetch() returns all data as String. # For example, they return 3.14 while Mysql::Result#fetch() returns "3.14". But I'm not sure these method names are appropriate and correct in English. Could you propose me if you have better names? -- regards, makoto kuwata