From: Robert Dober Date: 2008-08-30T03:07:26+09:00 Subject: Re: Class === On Fri, Aug 29, 2008 at 3:01 AM, Doug Glidden <41mortimer@gmail.com> wrote: > if x.is_a? Array > ... > end This is OT but as OP got lots of useful information already ;). Actually I much prefer A === x to x.is_a? Array Proof ;) Let us assume I am not a native English speaker, surely I prefer the symbolic name to the sophisticated auxiliary verb "to be" which happens to be irregular too, cans I has a Grammar please !!! and the indefinite article "a". If OTOH I were a native speaker I would be quite shocked that it reads is_a? instead of is_an?, would I not? (not! is not a method name!, as name! is not!.... ad infinitum) Q.E.D. Seriously #is_a? is more readable for sure but #=== has the advantage to pinpoint the possibility of using a *case* statement. Cheers Robert